Error: Cannot install Gobolinux on an UEFI system

Hi. I’m new on this forum and new to Gobolinux. But I look forward to trying out this linux.

At the start of the install of Gobolinux (terminal or startx), I’m getting the error:
“Error: cannot install Gobolinux on an UEFI system without an ESP partition.”

The PC that I’m using is an ASUS C202S (Chromebook with MrChromebox BIOS to boot linux), which can run either Mint or Gallium/OS just fine. So I was hoping to try out Gobolinux with this PC. The existing (usable and working) disk partitions are:

/dev/mmcblk0p1 - EFI System (512M) “/boot”
/dev/mmcblk0p2 - Linux swap (4G)
/dev/mmcblk0p3 - Linux filesystem (24.6G) - root “/”

But it would seem that the Gobolinux Installer does not recognize the EFI system partition on this disk device (mmcblk0p1), even though both fdisk and cfdisk recognize the EFI and other partitions, as does current Gallium/OS on this PC? I do not need to keep anything on this PC. But even if I select “format” to have the Installer use the entire disk, I still get the above error message. Any ideas? Thanks!


Hi @hashcakes congrats on checking out gobolinux! :slight_smile:

What filesystem is your efi partition formated? It should be fat32 afaik.

Also make sure the efi partition has the flag “boot” in gparted.

The way I always do it is pre-formating everything myself with gparted to prevent issues with the installer.

Hope that helps!

1 Like

Thanks nuc,

Yes the EFI partition is fat32. I will double check the boot flag and also try re-defining the partition using gparted.

It just seems odd to me. As I mentioned before, neither Linux Mint or or the current running Gallium/OS has a problem with this same EFI partition. Also when I boot up the Gobolinux install image, it finds my old swap space partition just fine and activates it. But the Installer can’t seem to find any of the existing partitions (swap, ‘/’ or EFI) on this oddly named “disk”. So I was thinking that maybe the Gobolinux Installer (Python program?) can’t deal with my goofy “disk device name” (/dev/mmcblk0p1, etc.) on my Asus chromebook? And maybe that’s the problem? Because this is not really a very “normal PC” for your average linux install.

Anyway, I will play around further with this PC (or another) and let you know.


I have some more information.

I had a look through the /usr/bin/GoboLinuxInstaller Python program. This program uses “partinfo” command, with " --name", " --fstype" and " --flags" options to collect the disk partitions information. When I run each of these “partinfo” commands on my Chromebook, these all do show the partition information correctly (eg. my esp partition has the “boot” flag on, fat32, etc.). But all of the “partinfo” commands are failing on my Chromebook with the error:
“Error: /System/Kernel/Devices/mmcblk0boot0: unrecognized disk label”
Followed by a backtrace and the final message of:
“A bug has been detected in GNU Parted.” … etc. Along with the version of 3.3 for “GNU parted”.

On checking the GNU parted website (Index of /gnu/parted), there is a newer version 3.5 available. I don’t know if the newer version will correct this problem. But I am guessing that bug that the “GNU parted v3.3” has (which the GoboLinuxInstaller is using) is not helping much.

I can provide you with the full error message and backtrace information if you need this. I just didn’t want to paste in tons more info into my update at this time. Please let me know.

Thanks and regards,


Thank you for the thorough investigation :thinking:
Sorry that you are experiencing such problems… Indeed that is a very strange error, never seen it before. Might def be due to some uniqueness of the chromebooks “hard drives”.

I agree with your assumption of gparted potentially hitting a bug due to being outdated. But it might also be kernel related I guess (the live image doesnt have a very recent kernel sadly).

Iirc I had tried to update our gparted recipe in the past but I did hit some issue.

It might be a bit surgical to try all of this from the live image for now sadly. If you have a different machine I’d recommend trying it there for now.

@yann-kaelig do you happen to have updated gparted on your side? If so, maybe you could lend @hashcakes a binary package? :joy::sweat_smile:

Ahh sorry it seems I have confused “gparted” with “gnu parted”…

Try updating parted like this:

# NewVersion parted 3.5

Should work. (if not, append the tar.xz url to the command)


# Compile parted

Please report if that successully updated gnu parted on your live cd.

1 Like

Hi @nuc,

The command:

  • “NewVersion parted 3.5”
    produces the error:
    fatal: not a git repository (or any of the parent directories): .git
    GetRecipe: Could not find parted in /Data/Compile/Recipes.
    NewVersion: Error getting recipe

The command:

  • “NewVersion parted 3.5
    produces the error:
    fatal: not a git repository (or any of the parent directories): .git
    GetRecipe: Could not find parted in /Data/Compile/Recipes.
    NewVersion: Error getting recipe

Here is the backtrace info which I mentioned earlier for the “partinfo” commands:

The commands:

  • “partinfo --name”, “partinfo --fstype” and “partinfo --flags”
    all produce errors which are very similar to the following error for “partinfo --name”:
    Error: /System/Kernel/Devices/mmcblk0boot0: unrecognized disk label
    Backtrace has 5 calls on stack:
    5: /lib/ [0x7fe17f2885e2]
    4: /lib/ [0x7fe17f28c92e]
    3: partinfo() [0x40122b]
    2: /lib/ [0x7fe17f0da8ab]
    1: partinfo() [0x40146a]
    A bug has been detected in GNU Parted. Refer to the web site of parted for more information of what could be useful for bug submitting! Please email a bug report to containing at least the version (3.3) and the following message: Assertion (disk != NULL) at disk.c:1547 in function ped_disk_next_partition() failed.
    zsh: abort partinfo --name

I also had a look at /Programs/ConfigTools/017/src/partinfo.c. It appears that this program does take into account ssd devices such as /dev/nvme0n1. But does it take into account my weird device (/dev/mmblk0) on my Asus Chromebook? I’m not a C programmer, so I can’t say for sure from looking at the partinfo.c source code. Just curious … I ask this because whenever I start the GoboLinuxInstaller, this program does not seem to find my disk partitions which I’ve previously setup using cfdisk, as well as flagged and formatted these.

You are probably right in that I may have to give up trying to install Gobolinux on this chromebook, for now.

Thanks and regards,